
Mobile measurement of fugitive CH4
emissions using the LI-7810

For researchers wanting to collect and visualize methane
concentration data associated with either multiple fixed loc-
ations, or while walking or driving, there are several ana-
lyzer options available, as well as associated tools to process
and visualize resulting data. With regards to the choice of
methane analyzer, the LI-7810 CH4/CO2/H2O Trace Gas
Analyzer is particularly well-suited to such applications.

Figure1. LI-7810 Trace Gas Analyzer and backpack har-
ness.

With sub-ppb precision in less than one second, the analyzer
can record very small changes in methane concentration
above background levels, making the detection of methane
emissions at very low levels a possibility. Importantly,
because of its extremely low-volume optical cavity design,
with a volume of just 6.41 cm3, the analyzer delivers
response time (T10-90%) of <2 seconds. This is significant
when moving at higher velocities when in a vehicle, or
where you may be crossing narrow emissions plumes, res-
ulting in transient increases in methane concentration.

To achieve the desired result, as shown in Figure 2 below,
time synchronized concentration and Global Positioning Sys-
tem (GPS) data are required. Once methane concentration
data and GPS data have been collected, you can visualize the
data with a suitable mapping tool. Google Earth Pro
provides an accessible and free to use platform for such an
application. The LI-7810 is not fitted with an internal GPS.
You can use an independent GPS device with the LI-7810
that meets the measurement frequency and precision needed
for your research, with data from both devices synchronized
in post-processing. The following describes two different
case studies where an external GPS was used to collect pos-
ition data, then synchronized with data from an LI-7810.

Figure2. Example CH4 concentration map, visualized in
Google Earth Pro.

Here we describe the essential, basic hardware and software
required to achieve a result such as that presented in Figure
2 above, along with step-by-step instructions for applying
these options to deliver the desired result.

Required equipment and software
We used the following hardware and software tools to meas-
ure and record methane concentration data and GPS data,
synchronize these data sets, convert the data sets to the Key-
hole Markup Language (KML) file format, and finally visu-
alize the resulting data set using Google Earth Pro:

1 LI-7810 Trace Gas Analyzer, with optional backpack
harness for walk-around surveys.
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2 Global Positioning System

We tested two options for GPS:
a Garmin eTrex 10 handheld GPS -

https://buy.garmin.com/en-US/US/p/87768

b Trails GPS app for iPhone, available in the Apple
App Store - https://apps.apple.com/gb/app/trails-
outdoor-gps-logbook/id913277014

3 Microsoft Excel

4 GEGraph -
http://www.sgrillo.net/googleearth/gegraph.htm

5 Google Earth Pro -
https://www.google.co.uk/earth/download/gep/agree
.html

Methods
The following describes the complete process of visualizing
concentration and GPS data in two different case studies.
The first is with the Garmin eTrex 10 handheld GPS. The
second case study demonstrates how to run the iPhone
Trails app and download data in GPX format. The data can
then be processed in a similar fashion to that detailed for the
Garmin eTrex 10.

During testing, we found that in a non-urban environment,
the Garmin eTrex 10 delivers reliable data at 1 Hz without
dropouts. The Trails app provided good accuracy in terms of
location, and at times data were delivered at a steady 1 Hz
rate, but data dropout was frequent, even at walking pace.

Before following this method, please familiarize yourself
with manuals for the LI-7810 and Garmin eTrex 10 and use
of the products themselves. The step-by-step instructions that
follow will be significantly clearer as a result.

Case Study 1: Methane Concentration and GPS
Data Visualization Using the LI-7810 and Garmin
eTrex 10

1 Initial Set-up of GPS and LI-7810

Unless otherwise stated, navigation is affected using the joy-
stick on the front panel as shown in Figure 3 below, with
commands entered by clicking this joystick.

Figure3. Garmin eTrex 10 handheld GPS.

Firstly, set up the unit to record data at a fixed time interval
of one second: Setup > Tracks > Record Method – Time > Set
Recording Interval to 00:00:01.

To view time on the Map screen of the Garmin GPS, follow
the following steps: Setup > Map > Data Fields > 1 large > Back
(side button) > Back (side button) > Map >Menu (side button) >
Change Data Fields > Select > Time of Day

Prior to starting either a walking or driving survey, it is
important to manually synchronize the time set on the LI-
7810 with that on the Garmin device. It is not possible to
automate this process or manually adjust the time on the
Garmin GPS since time is acquired via the satellite con-
nection. Time on the LI-7810 can be manually set via the
Network Control panel.

2 Record and Export GPSData

Initiate recording of a walk or drive as follows: Map > Hold
down stick > Select Map > Select Go

To complete and save recording of a walk or drive, follow
these steps:

Push back side button to leave Map > Track Manager > Current
Track > Save Track > Name and save file > Delete current track to
clear data (important as this file includes data from all tracks
recorded unless cleared). When saved, the file will be expor-
ted in GPX format.

Merging methane concentration data and
GPS data in Excel
After you have downloaded the LI-7810 data file and GPX
file, load the GPX file in Excel, and do the following:

1 Connect the Garmin GPS to a laptop via the USB cable
supplied with the unit.

2 OpenMicrosoft Excel and load the GPS data file.

Click File > Open > Browse to Garmin eTrex 10 > Garmin > GPX >
Select file in default folder and Open.

3 Ignore file format warning. Select Yes.

4 Select OK to open As an XML Table.
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5 Ignore schema sourcewarning. Select OK.

6 You will see aWorksheet populated as in Figure 4
below. We are interested in columns H and I (con-
taining latitude and longitude data) and column K (con-
taining time data), highlighted in red.

Figure4. Garmin GPS data exported to Microsoft Excel
via GPX file format.

We need to combine the latitude, longitude, and time data
in this file with methane concentration data collected by the
LI-7810.

To import LI-7810 data into Excel, work through the fol-
lowing steps:

1 OpenMicrosoft Excel and load the LI-7810 data file.

2 Click File > Open > Browse to relevant folder > Select ‘All Files’
at bottom right to see data file > Open data text file.

3 Use default Delimited and click Next.

4 Use default Tab delimited and click Next.

5 Use default General Column data format and click Fin-
ish.

6 You will see aWorksheet populated as in Figure 5
below. We are interested in the time data (in this case
column G) and methane concentration data (in this
case column J), highlighted in red.

Figure5. LI-7810 data exported to Microsoft Excel via
DATA file format.

At this point we need to bring the relevant data together in a
single Worksheet, ready for export to GEGraph as follows:

1 Open a newWorkbook in Microsoft Excel

2 Set up four tabs:
a TGAdata.

b GPS data.

c Combined data.

d Data for GEGraph.

3 Copy time and concentration data from the TGAdata
file to the TGAdataWorksheet in the newWorkbook.
Time in Column A, concentration in Column B.

4 Copy lat, long, and ns1:time2 data from the GPS data
file to the GPS dataWorksheet in the newWorkbook.
Ensure ns1:time2 data is in Column A, lat in Column
B, and long in Column C.

5 Remove text in time cells in the GPS dataworksheet
to obtain same format as TGAdata:
a Select all data in Column A (ns1:time2).

b Click Find & Select.

c Click Replace.

d In ‘Find what’ field enter the date on which the
datawas recorded followed by T, so YYYY-MM-
DDT. Leave ‘Replacewith’ field blank.

e Click ‘Replace All’.

f Repeat steps d & e, this time entering Z rather
than the date+T. You will now have time, lat, and
long data in columns A, B, and C.

6 Next copy and paste the time data and concentration
data in Columns A and B from the TGAdataWork-
sheet to Column A and B of the Combined dataWork-
sheet.

7 Nowuse the VLOOKUP function to bring across the
lat and long data into the Combined dataworksheet.
This will allow thematching of time, concentration,
lat, and long data, considering any dropouts in the
GPS data.

8 In cell C1 enter the following =VLOOKUP(A1,'GPS
data'!$A$1:$B$X,2,FALSE)

9 Double click on the bottom right of cell C1 to populate
lat data for all rows.

10 In cell D1 enter the following =VLOOKUP(A1,'GPS
data'!$A$1:$C$X,3,FALSE)

11 Double click on the bottom right of cell D1 to populate
long data for all rows.

12 Where X is the final row in the GPS dataWorksheet
data set.
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13 Finally, to prepare the data for cut and paste into
GEGraph, transpose Column B (concentration data)
to Column E, leaving Column B cells empty.

14 If you wish to visualize values only when they are
above the background concentration, an additional
step can be applied to subtract this from the con-
centration values. One approach is to find themin-
imum concentration in the data set and subtract this
from all values. Theminimum value can be found
using ‘=MIN(number1, number2,…)’.

Using GEGraph to visualize data in Google Earth
Pro
The data can now be visualized in Google Earth Pro via
GEGraph:

1 Open GEGraph.

2 In the example set-up shown in Figure 4 below, we
have set the footprint of the bar chart elements (poly-
gons) to be constant and set this to two meters; in
this casewith a square base, polygon sides 4. Height
is set to be according to value. The fill and outline of
the polygons have been set to red.

Figure6. GEGraph. Set-up for visualizing concentration
and GPS data in Google Earth Pro.

1 Data can now be cut and pasted from Excel into
GEGraph. Select all data in Columns B,C,D, and E in
the Combined dataWorksheet, omitting the first row
if this includes column headings. Copy data.

2 In GEGraph, click in the first cell on the first row. Click
‘Paste values’ button.

3 Click Run.

4 Enter a filename and click Save.

5 The file will be saved and Google Earth Pro launched
automatically. Datawill be visualized, as shown in the
example in Figure 5 below.

Figure7. Example methane concentration and GPS data
visualized in Google Earth Pro using Microsoft Excel
and GEGraph.

Case Study 2: Methane Concentration and GPS
Data Visualization Using the LI-7810 and Trails
iPhone App
The Trails app is set to 1 Hz data recording by default.
When using Trails, or an alternative GPS smart phone
application, we would suggest testing the application at the
frequency of the measurement you need, to ensure con-
sistency throughout the measuring period. As with the
Garmin GPS, LI-7810 and iPhone, times must be manually
synchronized. Time can be adjusted on either device to
match the other.

Follow the application instructions to record GPS data dur-
ing your survey. After GPS is recorded on the Trails, or sim-
ilar application, you can retrieve it through your personal
device or via email or a messaging service. The GPX file can
then be processed in a similar way to the GPX file generated
by the Garmin eTrex 10.
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References
Monitoring Methane Emissions with a Mobile Testing
Facility. See how The United Kingdom’s National Physical
Laboratory and Royal Holloway, University of London
assessed a mobile method for quantifying greenhouse gas
emissions with the LI-7810 Trace Gas Analyzer at
licor.com/env/products/trace_gas/mobile-testing-facility

Measuring Greenhouse Gas Emissions at Oktoberfest.
Learn how Prof. Chen and her team at the Technical
University of Munich investigated the relationship between
Oktoberfest and greenhouse gas emissions using the LI-7810
Trace Gas Analyzer at licor.com/env/products/trace_
gas/oktoberfest

Soil Gas Flux Studies: For soil chamber survey meas-
urements, LI-COR’s Smart Chamber features integrated
GPS, and the flux calculation software SoilFluxPro, which
includes data visualization via Google Earth Pro. Further
details regarding the Smart Chamber can be found here -
licor.com/env/products/soil_flux/survey.html – while inform-
ation concerning SoilFluxPro is available here -
licor.com/env/products/soil_flux/soilfluxpro.
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